Virtuous Payments Processing Issues

Minor incident Donations API
2022-11-18 10:15 MST · 30 minutes

Updates

Post-mortem

Issue is fully resolved after rolling back a recent update.

November 18, 2022 · 11:46 MST
Update

We have identified the issue related to a recent update. We have rolled back the update and we are monitoring for any further issues.

November 18, 2022 · 11:46 MST
Monitoring

Virtuous Payments is experiencing issues processing donations. We are investigating.

November 18, 2022 · 11:23 MST

← Back