Virtuous Platform Outage

Major incident CRM CRM API Forms API
2023-06-15 09:33 MST · 13 minutes

Updates

Resolved

Problem:
Virtuous Platform began experiencing indefinite loading screens between 9:33am MST - 9:46am MST.

Cause:
Virtuous’s third-party storage mechanism to log telemetry with each request was unavailable during a large spike in usage. Users were left with endless loading screens when the application could not communicate with the external storage system.

Fix:
The telemetry mechanism used with each request is no longer needed. It will be disabled, so any issues with the third-party storage mechanism will not cause indefinite loading screens within the application.
We’ll continue to investigate to determine why there was a large spike in storage usage.

June 15, 2023 · 09:51 MST
Monitoring

Services are being restored. We are monitoring further to ensure complete restoration of all services.

June 15, 2023 · 09:45 MST
Issue

We are currently investigating an issue that is causing access issues to the Virtuous Platform.

June 15, 2023 · 09:38 MST

← Back