Performance Issues in Virtuous CRM

Minor incident CRM
2023-08-21 11:03 MST · 2 hours, 55 minutes

Updates

Resolved

Performance in Virtuous CRM should now be back to normal. If you are still experiencing any performance issues on your end, please reach out to us directly at support@virtuous.org for assistance. We thank you for your patience and understanding during this time.

August 21, 2023 · 13:54 MST
Monitoring

Our team has taken action to address the ongoing performance issues with the Virtuous CRM application. We are actively monitoring the situation and are seeing promising initial results, with some metrics showing improvement. We appreciate your patience as we work diligently to ensure optimal performance and functionality.

August 21, 2023 · 12:08 MST
Issue

We have received multiple reports about system performance degradation in our Virtuous CRM application. Our technical team is actively working on identifying and resolving the underlying causes. We sincerely apologize for any inconvenience caused and appreciate your patience and understanding as we work to rectify this situation.

August 21, 2023 · 11:03 MST

← Back