Apple Users Experiencing Issues Loading Virtuous Forms

Minor incident Forms API
2024-04-12 06:54 MST · 6 hours, 59 minutes

Updates

Resolved

The issue is resolved on the Virtuous end. To track the status of the issue with Apple, you can follow the progress Here.

April 12, 2024 · 13:52 MST
Update

A hotfix has been released for Virtuous Forms to mitigate the issue on our end. Through our testing, we are able to successfully access forms through the latest version of MacOS and iOS. A comprehensive fix may not be available until a patch is issued by Apple. We thank you for your patience and understanding.

April 12, 2024 · 07:36 MST
Issue

Apple users using the latest update of Safari on MacOS or iOS may be experiencing issues loading Forms by Virtuous due to a bug introduced in the latest update provided by Apple. We are currently investigating and working to mitigate the issue. Due to the nature of the issue, a fix may not be available until a patch becomes available from Apple. Tracking the issue Here.

April 12, 2024 · 06:54 MST

← Back