Issues Logging into the Donor Portal

Minor incident Donor Portal
2024-08-28 06:52 MST · 47 minutes

Updates

Resolved

We have implemented a configuration change to address and resolve the issue. Our team has confirmed that the problem is fully resolved. We apologize for any inconvenience caused and appreciate your patience.

August 28, 2024 · 07:37 MST
Issue

We are currently investigating issues logging into the donor portal. We will provide another update shortly as we have more information. Apologies for the inconvenience.

August 28, 2024 · 06:52 MST

← Back