Virtuous CRM 2FA Code Delivery Interruption
      
Minor incident
      
        CRM
        Analytics
    
    
      
2024-11-12 10:29 MST
      
      · 3 hours, 18 minutes
    
  Updates
          Resolved
        
        
November 12, 2024 · 13:45 MST
        
      
      This issue has now been resolved. We appreciate your patience and understanding as we worked to address this interruption.
          Update
        
        
November 12, 2024 · 11:28 MST
        
      
      We’ve identified a fix for users affected by 2FA login issues and are currently deploying it. Our team is closely monitoring the situation to confirm the issue is fully resolved. Thank you for your patience.
          Issue
        
        
November 12, 2024 · 10:29 MST
        
      
  We are currently investigating an issue where some users are not receiving 2FA login codes when attempting to access Virtuous CRM. Our team is working to resolve this as quickly as possible. We appreciate your patience as we work toward a solution.
← Back