Virtuous Forms Failing to Load

Major incident Forms API
2025-01-28 10:37 MST · 5 minutes

Updates

Resolved

Our engineering team has resolved a DNS issue that was preventing Virtuous Lead and Giving forms from loading. Forms are now loading as expected. We will continue to monitor the situation.

January 28, 2025 · 10:42 MST
Issue

We are aware of an issue that is causing Virtuous Lead and Giving forms to fail to load. Our engineering team is on it and we are working on implementing a solution right away!

January 28, 2025 · 10:22 MST

← Back