Outage

Major incident CRM CRM API Forms API Donations API Donor Portal
2025-10-29 08:46 MST · 8 hours, 6 minutes

Updates

Resolved

All systems have fully recovered following the global Azure outage.

The temporary configuration put in place during the incident has been reverted, and we’ve verified that all systems are functioning as expected.

We’ll continue to monitor closely, but no further impact is anticipated. Thank you for your patience during this event.

October 29, 2025 · 16:53 MST
Monitoring

Microsoft has reported signs of recovery from the global Azure outage, and we can confirm that our systems are coming back online. Access to the application is being restored progressively.

We will continue to monitor closely as Azure completes their recovery efforts and will provide updates once all systems are fully operational.

October 29, 2025 · 15:08 MST
Investigating

Microsoft Azure is currently experiencing a global outage impacting multiple services. To mitigate the impact, we have worked with Microsoft to temporarily bypass their Front Door service in order to restore access to our application.

Access has been largely restored, though some services may not function and performance may remain degraded while Azure continues to resolve the underlying issue. We will revert this temporary configuration once the Azure outage is fully resolved.

October 29, 2025 · 10:26 MST
Issue

We are currently experiencing an outage affecting CRM functionality. This appears to be related to a widespread Azure service disruption impacting our infrastructure. Our engineering team is actively working with Microsoft to restore service as quickly as possible. Updates will be provided as more information becomes available.

October 29, 2025 · 08:46 MST

← Back