Users Unable to Access Virtuous Connect
Minor incident
Integrations
2025-11-06 07:54 MST
· 1 hour, 22 minutes
Updates
Resolved
November 6, 2025 · 09:16 MST
Access to Virtuous Connect has been restored. The issue was related to an on-disk key rotation that occurred several days ago. A reboot last night caused the app to load the new key, which led to authentication failures. A subsequent reboot this morning resolved the issue and restored normal access.
Issue
November 6, 2025 · 07:54 MST
We are currently investigating an issue preventing users from accessing Virtuous Connect. When attempting to access Connect within the CRM, users are being redirected to a login page instead of remaining authenticated.
Our engineering team is actively investigating and will provide updates as more information becomes available.
← Back