Quick Search Unavailable

Minor incident CRM Analytics
2025-11-25 09:55 MST · 7 hours, 57 minutes

Updates

Resolved

A DNS resolution issue affecting Quick Search has been resolved, and the feature is now functioning normally. We will continue monitoring to ensure full stability.

November 25, 2025 · 17:52 MST
Issue

Quick Search is currently unavailable. Our engineering team is aware and actively working on a fix. In the meantime, you may use Filters to search your data.

We will provide an updates as soon as we have more information.

November 25, 2025 · 17:35 MST

← Back