Significant Slowness
Major incident
CRM
Analytics
2025-12-03 09:30 MST
· 24 minutes
Updates
Monitoring
December 3, 2025 · 09:49 MST
Performance across the CRM is now appearing to return to normal. Server metrics have stabilized and are back within expected ranges.
We are continuing to monitor closely to ensure performance remains consistent. Further updates will be provided if needed.
Issue
December 3, 2025 · 09:30 MST
We are currently investigating an issue causing significant slowness across the Virtuous CRM+ platform. Some users may experience timeouts, long load times, or inability to complete actions.
Our engineering team is actively working to identify the cause and restore normal performance as quickly as possible. We will provide updates as soon as more information becomes available.
← Back