Intermittent System Slowness
Minor incident
CRM
Analytics
2025-12-15 11:59 MST
· 1 hour, 50 minutes
Updates
Monitoring
December 15, 2025 · 12:53 MST
We identified and mitigated an issue that caused intermittent slowness and error messages earlier today. System performance has stabilized, and key metrics have returned to normal ranges.
We are continuing to monitor closely while additional protections are being put in place to prevent a recurrence. Further updates will be shared if needed.
Issue
December 15, 2025 · 11:59 MST
Some customers are experiencing intermittent slowness and 500 error messages across portions of the platform. Our engineering team is aware of the issue and actively working to identify and implement a solution.
Updates will be provided as more information becomes available.
← Back