Intermittent Slowness in CRM+

Minor incident CRM Analytics
2025-12-29 09:10 MST · 1 hour, 19 minutes

Updates

Resolved

The issue causing intermittent slowness in Virtuous CRM+ for some customers has been resolved, and system performance has returned to normal operations.

December 29, 2025 · 10:30 MST
Monitoring

We’ve addressed the issue causing intermittent slowness in Virtuous CRM+ for some customers, and system performance has stabilized. Our team is closely monitoring the platform to ensure continued reliability.

December 29, 2025 · 10:05 MST
Investigating

We are seeing intermittent slowness in the CRM. Our team is aware of the issue and is actively working on a solution. Updates will be shared as we make progress.

December 29, 2025 · 09:10 MST

← Back