Analytics and Insights Data Delay
Minor incident
CRM
Analytics
2026-03-13 07:59 MST
· 4 hours, 26 minutes
Updates
Resolved
March 13, 2026 · 12:24 MST
Data is now displaying as expected for Analytics and Insights. Please reach out to support if additional unexpected latency is seen.
Issue
March 13, 2026 · 07:59 MST
We are currently investigating an issue where Virtuous Analytics and Insights are missing data from March 12. Our engineering team is actively working to identify the cause and restore the missing data.
We will provide updates as more information becomes available.
← Back