Intermittent System Slowness
Minor incident
CRM
Analytics
2026-04-09 09:21 MST
· 2 hours, 2 minutes
Updates
Resolved
April 9, 2026 · 10:57 MST
Internal teams have confirmed that the noted intermittent slowness is resolved. Please reach out to support should your organization see otherwise.
Issue
April 9, 2026 · 09:41 MST
We are currently experiencing intermittent slowness affecting some customers. Our engineering team is actively investigating the issue and working to restore normal performance.
We will provide updates as more information becomes available.
← Back