Virtuous Analytics and Data Share: Temporary Data Sync Issue

Minor incident CRM Analytics
2026-04-13 08:58 MST · 6 hours, 20 minutes

Updates

Resolved

Data is now displaying as expected for Virtuous Analytics and Data Share. Please reach out to support if additional unexpected latency is seen.

April 13, 2026 · 15:18 MST
Issue

We’re aware of the sync issue and are actively looking into it. Our engineering team is reviewing the data pipelines and sync processes to deploy a fix.

April 13, 2026 · 08:58 MST

← Back