Virtuous Analytics & Data Share: Temporary Data Sync Issue
Minor incident
CRM
Analytics
2026-04-24 07:30 MST
· 5 hours, 31 minutes
Updates
Resolved
April 24, 2026 · 12:56 MST
Internal teams have reported that this unexpected behavior related to the Analytics tool has been resolved. Testing has also confirmed that fix. Please reach out to our support team with further questions on this item if needed.
Issue
April 24, 2026 · 07:30 MST
We’re aware of the sync issue and are actively looking into it. Our engineering team is reviewing the data pipelines and sync processes to deploy a fix.
← Back