G&C Import Latency

Minor incident CRM Analytics
2026-05-04 14:36 MST · 2 weeks, 1 day, 1 hour, 2 minutes

Updates

Resolved

The issues with import latency has been resolved

May 19, 2026 · 15:38 MST
Monitoring

Internal teams have indicated that we should no longer be seeing Gift & Contact Import tool latency. We are closely monitoring this functionality to confirm that processing and importing objects result in expected site performance.

May 4, 2026 · 14:36 MST

← Back