Data Sync Behavior
Minor incident
CRM
Analytics
2026-05-26 10:37 MST
· 4 hours, 4 minutes
Updates
Resolved
May 26, 2026 · 14:40 MST
All data sync issues have been resolved as a result of engineering efforts to run a recovery sync. Please reach out to support with any additional questions/concerns regarding this brief unexpected behavior.
Issue
May 26, 2026 · 10:37 MST
Internal teams are currently investigating a data sync issue within the Virtuous platform. Recovery syncs are running now and should be complete by EOD. Please reach out to Virtuous Support with any unexpected behavior related to database syncing.
← Back