Save and Continue/Close Import Behavior

Minor incident CRM Analytics
2026-06-04 08:11 MST · 23 hours, 59 minutes

Updates

Resolved

The ‘Save and Continue’ and ‘Save and Close’ button functionality within the Gift and Contact Import tool has been restored as of yesterday evening. Please resume using these buttons in the import tool and follow up with Virtuous Support should your organization experience any further unexpected behavior.

June 5, 2026 · 08:06 MST
Monitoring

Our team is closely monitoring the fix that has been applied to allow for the Save and Continue and Save and Close buttons to function as expected. Please continue to monitor this page for further updates this afternoon.

June 4, 2026 · 12:21 MST
Monitoring

Customers who have the Social Insights feature enabled in their site may be experiencing some unexpected behavior around saving changes in the Gift and Contact Import tool. Our internal teams are working to resolve this as a top priority this morning.

June 4, 2026 · 08:11 MST

← Back