Contact Record Navigation Tabs Temporarily Disappears

Minor incident CRM Analytics
2026-06-04 12:28 MST · 2 hours, 5 minutes

Updates

Resolved

The Contact Record Navigation Tabs issue has been resolved and is now functioning normally. We will continue monitoring to ensure full stability.

June 4, 2026 · 14:32 MST
Issue

We are aware of an issue where the navigation tab on the contact record temporarily disappears. Our engineering team is aware and actively working on a fix.

We will provide updates as soon as we have more information.

June 4, 2026 · 12:28 MST

← Back