Virtuous Analytics: Temporary Sync Issue Affecting Data from 6/24/26
Minor incident
CRM+
Analytics
2026-06-25 07:30 MST
· 5 hours, 55 minutes
Updates
Update
June 25, 2026 · 10:45 MST
We are currently processing the sync. Our estimated time to resolution is approximately 5.5 hours. We appreciate your patience while this is being resolved.
Issue
June 25, 2026 · 07:30 MST
We’re aware of the sync issue and are actively looking into it. Our engineering team is reviewing the data pipelines and sync processes to deploy a fix.
← Back