Data Sync Delay

Minor incident CRM+ Analytics
2026-07-08 08:23 MST · 4 hours, 19 minutes

Updates

Resolved

The issue causing a delay in displaying data entered yesterday has been resolved. Gifts, contacts, and contact notes are now syncing and appearing as expected.
We apologize for the disruption.

July 8, 2026 · 12:43 MST
Issue

We are investigating an issue causing a delay in displaying data entered yesterday. Gifts, contacts, and contact notes may not be appearing as expected. Our engineering team has identified the issue and is working on a fix.

We will provide updates as more information becomes available.

July 8, 2026 · 08:23 MST

← Back