Workflows/Automations Running Delayed
Minor incident
CRM+
CRM+ App
2026-07-08 09:01 MST
· 1 week, 4 hours, 31 minutes
Updates
Investigating
July 14, 2026 · 09:49 MST
The majority of workflows have been confirmed to have been working as expected as of last week. Our engineering team is reviewing specific instances where workflows continue to be delayed for certain organizations.
Monitoring
July 10, 2026 · 09:20 MST
Close monitoring of workflows/automations seem to indicate that this unexpected behavior has been resolved. Our team will continue to track workflow performance this afternoon to confirm full resolution by end of today.
Issue
July 8, 2026 · 09:01 MST
Multiple orgs have reported unexpected behavior with Automations not running in the early morning as expected, and instead being delayed. In some cases, those automations do not run at all. Our team is actively investigating this as a top priority today
← Back